This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Bienvenido, Invitado
Tienes que registrarte para poder participar en nuestro foro.

Nombre de usuario
  

Contraseña
  





Estadísticas del foro
» Miembros: 16,353
» Último miembro: umuewadekuqub
» Temas del foro: 11,809
» Mensajes del foro: 115,464

Estadísticas totales

Últimos temas
¿Makers en Asturias?
Foro: Puntos Maker
Último mensaje por: BembaCam
Hace 22 minutos
» Respuestas: 10
» Vistas: 3,214
Artillery Genius se calie...
Foro: Artillery
Último mensaje por: Simemart
Hace 10 horas
» Respuestas: 1
» Vistas: 0
Proyecto conversion Ender...
Foro: CoreXY
Último mensaje por: Macuho
Ayer, 04:56 PM
» Respuestas: 1
» Vistas: 0
Reconocimiento MCU en Kli...
Foro: Firmware y Software
Último mensaje por: Macuho
Ayer, 04:54 PM
» Respuestas: 1
» Vistas: 0
Autolevel, paso a paso (I...
Foro: Anet
Último mensaje por: Simemart
Ayer, 11:12 AM
» Respuestas: 189
» Vistas: 51,548
Ender 3 V2 el extrusor se...
Foro: General
Último mensaje por: Simemart
28-02-2024, 05:53 PM
» Respuestas: 1
» Vistas: 0





















 
  Reconocimiento MCU en Klipper
Enviado por: JavierFdLS - 28-02-2024, 11:59 PM - Foro: Firmware y Software - Respuestas (1)

Hola y gracias por leer...

Tengo 2 impresoras con la misma placa la MKS Gen_L v1.0 fueron reemplazadas en 2 ANET A8
El caso es que al realizar la identificación del MCU

ls /dev/serial/by-id/* o desde KIAUH

Devuelve como resultado

/dev/serial/by-id/usb-1a86_USB_Serial-if00-port0

Cambio a la otra impresora (tambien con la MKS Gen_L v1.0) y curiosamente devuelve el mismo resultado
/dev/serial/by-id/usb-1a86_USB_Serial-if00-port0

Y si están ambas conectadas, aparece solo un resultado y desde KIAUH lo mismo ni siquiera el 2do MCU #2 habitual aunque sean dos Arduino UNO o dos MEGA2560 que si aparecen los dos ID MCU

No se si hay forma de agregar algo para poder identificar de forma un poco más precisa cada placa para así poder operarlas conectadas en simultáneo

Otros ejemplo que pude ir comprobando con placas prestadas dan como resultados:
MCU#1   (Arduino Mega 2560 + RAMPS 1.4)
/dev/serial/by-id/usb-Arduino__www.arduino.cc__0043_xxxxxxxxxxxxxxxxxxxx-if00
MCU#2   (Arduino Mega 2560 + RAMPS 1.4)
/dev/serial/by-id/usb-Arduino__www.arduino.cc__0043_xxxxxxxxxxxxxxxxxxxx-if00
MCU#3   (Arduino Mega 2560 + RAMPS 1.4)
/dev/serial/by-id/usb-Arduino_Srl_Arduino_Mega_xxxxxxxxxxxxxxxxxxxxx-if00
MCU#4   (MKS RUMBA+   solo probé la placa suelta)
/dev/serial/by-id/usb-Arduino__www.arduino.cc__0042_xxxxxxxxxxxxxxxxxxxx-if00
MCU #5   (MKS TinyBee   no logro que funcione)
/dev/serial/by-id/usb-1a86_USB_Serial-if00-port0


O algún otro resumen o forma de llegar a los datos como para formal el identificador



Muchas gracias


  Ender 3 V2 el extrusor se afloja y eleva
Enviado por: _.alexbv - 28-02-2024, 12:59 PM - Foro: General - Respuestas (1)

Buenas, tengo una Ender 3 V2 comprada recientemente, y me he dado cuenta que al imprimir la rueda extrusora se afloja y se eleva, tras 1 hora y media de impresión me encuentro con que se ha levantado, y al quitar el filamento se cae, los chivatos estan bastantes apretados y el tornillo del muelle lo aflojé pero sigue estando el mismo fallo, cada vez que imprimo algo al rato si aprieto la pieza del muelle se baja la rueda extrusora, por el resto imprime perfectamente y no da problemas.

¿Se os ocurre que puede pasar?

Gracias!!

[Imagen: Whats-App-Image-2024-02-27-at-13-19-06.jpg]


  Pequeñas paradas
Enviado por: Etimoe - 27-02-2024, 02:46 PM - Foro: General - Respuestas (2)

Hola a todos
Recientemente desmonte mi cartesiana casera para montar una Corexy
Todos los materiales son aprovechados.
En Marlin solo cambie el tipo de impresora a Coreyx.
Tengo skr 1.3 tmc 2130 spi y después de algunos ajustes imprime perfecto.
Hasta que imprimí una pieza en modo vaso o espiral , si los perímetros son rectos bien , pero si son curvos hace pequeñas paradas aleatorias dejando marcas.
He bajado velocidad pero pero no hace nada. ( No se me ocurre mucha cosa)
Tanto Marlin como laminador son los mismos.
Cuando era Cartesiana lo hacía bien.
Si alguien  me puede ayudar?

Gracias


  Proyecto conversion Ender 3 v2 a corexy, necesito consejos y problemas con drivers
Enviado por: Miyi3D - 26-02-2024, 03:19 PM - Foro: CoreXY - Respuestas (1)

Buenos dias/tardes/noches, me presento, me llamo Mijailo, soy nuevo en el foro y tengo una Ender 3v2 a la cual dentro de poco le va a quedar poco de Ender 3v2 ya que le voy a hacer una conversión a corexy con sistema toolchanger para imprimir hasta 4 colores, y para eso elegí como electrónica la placa bigtreetech manta m8p con el modulo cb1 corriendo klipper, actualmente tengo a mi Ender 3v2 funcionando con esta electrónica imprimiendo las piezas para armar la nueva impresora, pero tengo un problemita que aun no he podido solucionar, y es que el motor del eje y calienta mucho, es un nema 17 42-34, antes calentaban todos los motores pero lo fui solucionando ajustando el run_current, el tema es que en el caso del eje y, si bajo mas la corriente, pierde pasos, y si la subo lo suficiente como para que no pierda pasos, recalienta, asi que no se que mas puedo hacer, tal vez deberia probar a poner un motor mas grande manteniendo la misma corriente, como un nema 17 42-40, pero no se me ocurre otra cosa, por cierto, estoy usando los drivers tmc2209 y aqui les dejo mi printer.cfg:

[include mainsail.cfg]

[include KAMP_Settings.cfg]
[include ./KAMP/Adaptive_Meshing.cfg]
#[include ./KAMP/Voron_Purge.cfg]
[include ./KAMP/Smart_Park.cfg]
[include macros.cfg]

# host MCU service is preinstalled and ready to use with:
[mcu CB1]
serial: /tmp/klipper_host_mcu

[mcu]
serial: /dev/serial/by-id/usb-Klipper_stm32h723xx_44002B001251313236343430-if00

[exclude_object]

[printer]
kinematics: cartesian
max_velocity: 300
max_accel: 3000
max_z_velocity: 5
max_z_accel: 100



#_________________________________________CONFIGURACION EJE X_________________________________________________

[stepper_x]
step_pin: PE6
dir_pin: PE5
enable_pin: !PC14
microsteps: 16
rotation_distance: 40
endstop_pin: tmc2209_stepper_x:virtual_endstop
position_endstop: -9
position_min: -9
position_max: 235
homing_speed: 70
homing_retract_dist: 0

[tmc2209 stepper_x]
uart_pin: PC13
diag_pin: PF4
run_current: 0.800
stealthchop_threshold: 999999
driver_SGTHRS: 127
run_current: 0.500
interpolate: True

#_________________________________________CONFIGURACION EJE Y_________________________________________________

[stepper_y]
step_pin: PE2
dir_pin: !PE1
enable_pin: !PE4
microsteps: 16
rotation_distance: 40
endstop_pin: tmc2209_stepper_y:virtual_endstop
position_endstop: -8
position_min: -8
position_max: 224
homing_speed: 70
homing_retract_dist: 0

[tmc2209 stepper_y]
uart_pin: PE3
diag_pin: PF3
stealthchop_threshold: 999999
driver_SGTHRS: 127
run_current: 0.600
interpolate: True

#_________________________________________CONFIGURACION EJE Z_________________________________________________

#EJE Z IZQUIERDO
[stepper_z]
step_pin: PB8
dir_pin: PB7
enable_pin: !PE0
microsteps: 16
rotation_distance: 8
endstop_pin: probe:z_virtual_endstop
position_max: 250
position_min: -3
homing_speed: 8
second_homing_speed: 3
homing_retract_dist: 3

[tmc2209 stepper_z]
uart_pin: PB9
diag_pin: PF2
run_current: 0.800
stealthchop_threshold: 999999

#EJE Z DERECHO
[stepper_z1]
step_pin: PB4
dir_pin: !PB3
enable_pin: !PB6
microsteps: 16
rotation_distance: 8
#endstop_pin: probe:z_virtual_endstop
#position_max: 240
#position_min: 0
#homing_speed: 10
#second_homing_speed: 3
#homing_retract_dist: 3

[tmc2209 stepper_z1]
uart_pin: PB5
diag_pin: PF1
run_current: 0.800
stealthchop_threshold: 999999

#________________________CONFIGURACION SAFE Z HOME___________________
[safe_z_home]
home_xy_position: 150,100
speed: 70
z_hop: 10
z_hop_speed: 30

#________________________CONFIGURACION AJUSTE DE EJES Z_________________
[z_tilt]
speed: 50
horizontal_move_z: 5
retries: 10
retry_tolerance: 0.025
z_positions: 52, 100
  235, 100
points: 52, 100
  235, 100

#_________________________________________CAMA CALIENTE_________________________________________________

[heater_bed]
heater_pin: PF5
sensor_pin: PB1 # TB
sensor_type: Generic 3950
#control: pid
#pid_Kp: 10
#pid_Ki: 0.023
#pid_Kd: 305.4
min_temp: 0
max_temp: 130

#_________________________________________EXTRUSOR Y HOTEND 0_________________________________________________

[extruder]
#extrusor hotend 0
step_pin: PG13
dir_pin: !PG12
enable_pin: !PG15
microsteps: 16
max_extrude_cross_section: 5
#rotation_distance: 33.500
rotation_distance: 7.825
#gear_ratio: 3:1

#hotend 0
heater_pin: PA0
sensor_type: Generic 3950
sensor_pin: PB0
control: pid
pid_Kp: 21.528
pid_Ki: 1.451
pid_Kd: 88.212
min_temp: 0
max_temp: 260
nozzle_diameter: 0.4
filament_diameter: 1.75

[tmc2209 extruder]
uart_pin: PG14
run_current: 0.500
stealthchop_threshold: 999999

#_________SENSOR DE FILAMENTO_________
[filament_switch_sensor my_sensor]
pause_on_runout: True
switch_pin: !PF10
#runout_gcode:
#  A list of G-Code commands to execute after a filament runout is
#  detected. See docs/Command_Templates.md for G-Code format. If
#  pause_on_runout is set to True this G-Code will run after the
#  PAUSE is complete. The default is not to run any G-Code commands.
#insert_gcode:
#  A list of G-Code commands to execute after a filament insert is
#  detected. See docs/Command_Templates.md for G-Code format. The
#  default is not to run any G-Code commands, which disables insert
#  detection.
#event_delay: 3.0
#  The minimum amount of time in seconds to delay between events.
#  Events triggered during this time period will be silently
#  ignored. The default is 3 seconds.
#pause_delay: 0.5
#  The amount of time to delay, in seconds, between the pause command
#  dispatch and execution of the runout_gcode. It may be useful to
#  increase this delay if OctoPrint exhibits strange pause behavior.
#  Default is 0.5 seconds.


#_________________________________________________________VENTILADORES______________________________________________
# ventilador de capa
[fan]
pin: PF7
max_power: 1
#cycle_time: 0.010
#hardware_pwm: False
#kick_start_time: 0.100

#ventilador de hotend 0
[heater_fan fan1]
pin: PF9

#ventilador de placa
[fan_generic placa]
pin: PA4
max_power: 1

#__________________Configuración del BLTouch____________
[bltouch]
sensor_pin: PD13
control_pin: PD12
pin_move_time: 0.680
samples: 2
speed: 2
#z_offset: 0

#_________________Configuracion de malla normal generada por bltouch (no kamp)________________
[bed_mesh]
speed: 120
horizontal_move_z: 5
mesh_min: 52, 13
mesh_max: 235, 224
probe_count: 3, 3
mesh_pps: 2,2
fade_start: 1
fade_end: 10
fade_target: 0

#*# <---------------------- SAVE_CONFIG ---------------------->
#*# DO NOT EDIT THIS BLOCK OR BELOW. The contents are auto-generated.
#*#
#*# [bltouch]
#*# z_offset = 0.700
#*#
#*# [heater_bed]
#*# control = pid
#*# pid_kp = 69.735
#*# pid_ki = 1.453
#*# pid_kd = 836.816
#*#
#*# [bed_mesh default]
#*# version = 1
#*# points =
#*# 0.468753, 0.505003, 0.282503
#*# -0.087497, 0.055003, -0.052497
#*# -0.432497, -0.144997, -0.071247
#*# x_count = 3
#*# y_count = 3
#*# mesh_x_pps = 2
#*# mesh_y_pps = 2
#*# algo = lagrange
#*# tension = 0.2
#*# min_x = 52.0
#*# max_x = 235.0
#*# min_y = 13.0
#*# max_y = 224.0



Volviendo a lo de los consejos, quiero alcanzar los 600mm/s y soy nuevo con klipper, asi que configuraciones mecanicas y de firmware me recomiendan? y para el sistema toolchanger, busco un sistema que sea lo mas sencillo y confiable posible sin usar canbus, por lo menos por ahora, que me recomiendan?


  MKS Robin Nano V1.2
Enviado por: Pedro santo - 26-02-2024, 12:39 PM - Foro: Firmware y Software - Respuestas (1)

Hola amigos: necesito ayuda en una elegoo Neptune 2S, compre una placa Robin Nano y no me funcionan los motores ,son TCM 2209 y no hay manera de que funcionen, he intentado varias formas ,pero es todo inútil  ¿alguna ayuda?. Gracias de antemano amigos