This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 1 voto(s) - 1 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Linear Advance Configuracion e impresion
#1
Hola a todos !
Hace un tiempo configuré el linear Advance en Marlin 2.12para poder utilizarlo en mi impresora. Hice las pruebas con algunos materiales y determine sus factores K.
Pues bien tanto en PrusaSlicer  como en Cura introduzco lineas en el Gcode para modificar este parametro para cada impresion, pero cuando empiezo a imprimir en la pantalla me aparece un mensaje que el factor K =0, que es el valor guardado en la EPROM, si yo guardo 0,5, aparece 0,5. y creo que pasa olimpicamente del factor K que yo introduzco en el codigo. Por ejemplo 
; Filament gcode
M900 k0.1

¿Alguien me sabria decir como solucionar esto ?

Gracias por adelantado
  Responder
#2
Hola, si escribes el comando tal y como lo has puesto en el mensaje, yo diría que el problema es esa k minúscula, pues en Marlin los parámetros sólo se procesan si se escribe su letra identificativa en mayúsculas.
Según la página del Linear Advance, si se va a fijar el factor K con el comando M900, lo más apropiado es colocar en el firmware un valor 0 para el parámetro ADVANCE_K.
  Responder
#3
(09-08-2023, 10:14 PM)Simemart escribió: Hola, si escribes el comando tal y como lo has puesto en el mensaje, yo diría que el problema es esa k minúscula, pues en Marlin los parámetros sólo se procesan si se escribe su letra identificativa en mayúsculas.
Según la página del Linear Advance, si se va a fijar el factor K con el comando M900, lo más apropiado es colocar en el firmware un valor 0 para el parámetro ADVANCE_K.

Anda que como sea eso...
Si, lo he puesto en minusculas
Lo pruebo y te digo

Gracias
  Responder
#4
Confirmado era la letra k en minuscula, en cuanto la he puesto en mayuscula todo perfecto.

Gracias
  Responder
#5
Me alegro de que se haya solucionado.
Un saludo.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Ayuda configuracion del Marlin para compilar en el arduino NOQUI 1 99 13-02-2024, 06:06 PM
Último mensaje: Simemart
  Configuracion de ventiladores Marlin 21Curiosos 16 1,218 19-06-2023, 08:22 PM
Último mensaje: wolf
  Power Loss Recovery Configuracion bbouett 1 36 07-06-2023, 08:07 PM
Último mensaje: Simemart
  Configuración Marlin para 2 extrusores Luisdjnas 63 742 05-06-2023, 11:36 AM
Último mensaje: Luisdjnas
  Configuracion Prusaslicer Tomas007 0 27 20-04-2023, 09:05 PM
Último mensaje: Tomas007