This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema conexión impresora a PC
#1
Triste 
Buen dia muchachos/as, el dia de hoy me encontraba realizando pruebas con un nuevo filamento (tpu) y resulta que cuando inicia el ventilador de capa la temperatura de la boquilla empieza a descender (hasta antes que manejaba menos temperatura con el PLA funcionaba bien), investigando me di cuenta q como yo habia cambiado la placa el PID ni lo habia tocado, puse el que tenia la placa anterior, resulta que ahora estoy intentando configurar el PID en el pronterface pero no logro que me reconozca la impresora, conecto la impresora y ni la pc me la reconoce. Probando me di cuenta que si conecto la impresora a la pc sin que la impresora este conectada a 220v se prende la pantalla y me aparece un mensaje de error conex TMC, no tengo idea si tiene algo que ver pero lo comento por las dudas.
Alguno tiene idea porque la PC no me reconoce la impresora? sera algun sistema de seguridad o basicamente la impresora no es capaz de identificarse ante la computadora? La placa es nueva, es una SKR MINI E3 v2 en una ender 2 pro, espero que me puedan dar una mano que ya me tiene bastante frustrado esto jaja, saludos y buena semana muchachos.
  Responder
#2
Hola @Tomas007, bienvenido al foro.
La conexión USB de estas placas es problemática y su correcto funcionamiento puede depender del firmware que tenga instalado: ¿es el que facilita el fabricante o lo has compilado tú mismo?
No sé si lo estarás haciendo así pero, para saber si el PC reconoce la conexión de la placa, lo mejor es abrir antes el Administrador de dispositivos para saber si hay algún cambio en él al realizar la conexión: en todo caso, lo que debes comprobar es que el problema no esté en la conexión, utilizando otro cable USB y/u otro puerto del PC.
Que la pantalla se encienda al conectar por USB es normal, pues la línea de 5V interna está  conectada a la del conector USB; el error de conexión de los TMC también es normal en esta situación, pues estos necesitan la alimentación de la fuente para funcionar de forma correcta.
Que el hotend caiga de temperatura al conectarse el ventilador de capa, puede deberse también a una orientación inadecuada del flujo de aire, que incida en el cubo calentador en lugar de en la punta de la boquilla: si has cambiado el hotend, quizá te haya quedado más bajo y/o debas orientar mejor el flujo de aire.
El PID no depende de la placa, sino del hotend: si no se cambia este, no tendría porqué variar la regulación.
  Responder
#3
(03-02-2023, 11:42 AM)Simemart escribió: Hola @Tomas007, bienvenido al foro.
La conexión USB de estas placas es problemática y su correcto funcionamiento puede depender del firmware que tenga instalado: ¿es el que facilita el fabricante o lo has compilado tú mismo?
No sé si lo estarás haciendo así pero, para saber si el PC reconoce la conexión de la placa, lo mejor es abrir antes el Administrador de dispositivos para saber si hay algún cambio en él al realizar la conexión: en todo caso, lo que debes comprobar es que el problema no esté en la conexión, utilizando otro cable USB y/u otro puerto del PC.
Que la pantalla se encienda al conectar por USB es normal, pues la línea de 5V interna está  conectada a la del conector USB; el error de conexión de los TMC también es normal en esta situación, pues estos necesitan la alimentación de la fuente para funcionar de forma correcta.
Que el hotend caiga de temperatura al conectarse el ventilador de capa, puede deberse también a una orientación inadecuada del flujo de aire, que incida en el cubo calentador en lugar de en la punta de la boquilla: si has cambiado el hotend, quizá te haya quedado más bajo y/o debas orientar mejor el flujo de aire.
El PID no depende de la placa, sino del hotend: si no se cambia este, no tendría porqué variar la regulación.

Te agradezco por tu pronta respuesta, el firmware lo compile yo, ya que no habia un compilado ya hecho para la ender 2 pro, por lo cual me vi obligado a agarrar el firmware de la ender 2 pro y compararlo con el de la skr e3 mini v2 para ender 3, haciendo las modificaciones que segun en su momento me parecieron correctas jaja porque era y aun soy bastante novato, en cuanto al PID si no me equivoco le deje el de la ender 3 siendo asi posible que este sea el fallo ahora que me pongo a pensar, de todos modos lo que me comentas de que el flujo de aire quizas le de al cartucho calentador puede ser esa opcion tambien, ya que le coloque un satsana de ender 2 pro y el mismo aun esta medio flojo (tengo que comprarle mas tornillos) y posiblemente debido a eso el aire este yendo hacia el cartucho calefactor. Revisare estas dos cosas y luego te comento si pude solucionar el problema, muchas gracias por la ayuda!!
  Responder
#4
(03-02-2023, 12:58 PM)Tomas007 escribió:
(03-02-2023, 11:42 AM)Simemart escribió: Hola @Tomas007, bienvenido al foro.
La conexión USB de estas placas es problemática y su correcto funcionamiento puede depender del firmware que tenga instalado: ¿es el que facilita el fabricante o lo has compilado tú mismo?
No sé si lo estarás haciendo así pero, para saber si el PC reconoce la conexión de la placa, lo mejor es abrir antes el Administrador de dispositivos para saber si hay algún cambio en él al realizar la conexión: en todo caso, lo que debes comprobar es que el problema no esté en la conexión, utilizando otro cable USB y/u otro puerto del PC.
Que la pantalla se encienda al conectar por USB es normal, pues la línea de 5V interna está  conectada a la del conector USB; el error de conexión de los TMC también es normal en esta situación, pues estos necesitan la alimentación de la fuente para funcionar de forma correcta.
Que el hotend caiga de temperatura al conectarse el ventilador de capa, puede deberse también a una orientación inadecuada del flujo de aire, que incida en el cubo calentador en lugar de en la punta de la boquilla: si has cambiado el hotend, quizá te haya quedado más bajo y/o debas orientar mejor el flujo de aire.
El PID no depende de la placa, sino del hotend: si no se cambia este, no tendría porqué variar la regulación.

Te agradezco por tu pronta respuesta, el firmware lo compile yo, ya que no habia un compilado ya hecho para la ender 2 pro, por lo cual me vi obligado a agarrar el firmware de la ender 2 pro y compararlo con el de la skr e3 mini v2 para ender 3, haciendo las modificaciones que segun en su momento me parecieron correctas jaja porque era y aun soy bastante novato, en cuanto al PID si no me equivoco le deje el de la ender 3 siendo asi posible que este sea el fallo ahora que me pongo a pensar, de todos modos lo que me comentas de que el flujo de aire quizas le de al cartucho calentador puede ser esa opcion tambien, ya que le coloque un satsana de ender 2 pro y el mismo aun esta medio flojo (tengo que comprarle mas tornillos) y posiblemente debido a eso el aire este yendo hacia el cartucho calefactor. Revisare estas dos cosas y luego te comento si pude solucionar el problema, muchas gracias por la ayuda!!

Ya saque el satsana y coloque el original, ahora probando me di cuenta que cuando caliento por encima de los 212 grados con el ventilador al 100 no puede subir mas que eso, puede ser el cartucho calentador? quizas esta fallando y no logra calentar lo que debe, nunca lo cambie y ya tiene unos 7 meses aprox la impresora, desde ahi fue donde queme la placa madre, la razon por la cual puse una skr, habia cambiado el termistor q estaba quemado pero no el cartucho calefactor...
  Responder
#5
¿Has probado a calentar sin el ventilador encendido? Si así sube bien la temperatura, tiene que ser que el ventilador incide directamente en el cubo calentador; si tampoco sube, entonces es el cartucho.
Habría que medir la resistencia que tiene para saber su estado: normalmente suelen ser de 40W y en ese caso, si la alimentación es a 12V, debería dar unos 3,6 Ohms; si la alimentación es a 24V, unos 14,4 Ohms.
Para medir su resistencia, debes desconectar sus cables en la placa.

P.S.: Mucho cuidado cuando trabajes en cualquier parte de la impresora, debes desconectarla antes o te arriesgas a tener que volver a cambiar la placa. Verifica también el estado de la entrada de los cables en el cartucho calefactor y si los ves deteriorados, cámbialo antes de que se produzca un cortocircuito y la placa pase a mejor vida.
  Responder
#6
(03-02-2023, 02:32 PM)Simemart escribió: ¿Has probado a calentar sin el ventilador encendido? Si así sube bien la temperatura, tiene que ser que el ventilador incide directamente en el cubo calentador; si tampoco sube, entonces es el cartucho.
Habría que medir la resistencia que tiene para saber su estado: normalmente suelen ser de 40W y en ese caso, si la alimentación es a 12V, debería dar unos 3,6 Ohms; si la alimentación es a 24V, unos 14,4 Ohms.
Para medir su resistencia, debes desconectar sus cables en la placa.

P.S.: Mucho cuidado cuando trabajes en cualquier parte de la impresora, debes desconectarla antes o te arriesgas a tener que volver a cambiar la placa. Verifica también el estado de la entrada de los cables en el cartucho calefactor y si los ves deteriorados, cámbialo antes de que se produzca un cortocircuito y la placa pase a mejor vida.

Bueno, se me paso una idea por la cabeza la cual la lleve a cabo y me dieron buenos resultados, analizando lo que me comentabas pude ver que el cartucho calefactor anda de 10, calienta lo que debe calentar. La prueba que realice fue la siguiente, puse la temperatura a 220 y empece a aumentar la velocidad de los ventiladores de 10% en 10% cada 5 minutos, con lo cual me di cuenta que pasando el 90% la temperatura empieza a decender, teniendo en cuenta esto voy a empezar a utilizar en estas temperaturas el ventilador en 80% para evitar inconvenientes, pero supongo que debe ser por el PID pero dado que no me reconoce la impresora no lo voy a poder solucionar, puede ser que cambiando el Marlin pueda solucionar el problema de que no me reconoce la impresora la compu?
  Responder
#7
Por lo que he podido ver, una forma de solucionar este problema estaba en cambiar la versión de PlatformIO con la que se realizaba la compilación del firmware, pero desde entonces ha habido muchas versiones y eso debería estar resuelto a estas alturas, por lo que no sé si conseguirás algo con el cambio; en todo caso, por probar no pierdes nada.
Si quieres, antes de hacerlo puedes adjuntar los archivos de configuración que vas a utilizar y les echo un vistazo, por si veo algo que no tengas bien.
  Responder
#8
(03-02-2023, 03:49 PM)Simemart escribió: Por lo que he podido ver, una forma de solucionar este problema estaba en cambiar la versión de PlatformIO con la que se realizaba la compilación del firmware, pero desde entonces ha habido muchas versiones y eso debería estar resuelto a estas alturas, por lo que no sé si conseguirás algo con el cambio; en todo caso, por probar no pierdes nada.
Si quieres, antes de hacerlo puedes adjuntar los archivos de configuración que vas a utilizar y les echo un vistazo, por si veo algo que no tengas bien.

Dale seria genial, pero como adjunto los archivos de configuracion? intente varias cosas pero me dice que no tengo permitido subir estos archivos y que seleccione otros.
  Responder
#9
Debes incluirlos los dos en un archivo comprimido, tipo ZIP o RAR.
  Responder
#10
(03-02-2023, 04:30 PM)Simemart escribió: Debes incluirlos los dos en un archivo comprimido, tipo ZIP o RAR.

Disculpa tantas preguntas, pero te paso alguna carpeta en particular? porque la carpeta general donde esta toda la info, donde se guarda el github y .pio .vscode etc pesa demasiado y no me deja mandarlo a pesar de que este comprimido
  Responder
#11
La configuración de Marlin se encuentra en dos archivos, Configuration.h y Configuration_adv.h: solo debes incluir en el archivo comprimido esos dos.
  Responder
#12
(03-02-2023, 10:13 PM)Simemart escribió: La configuración de Marlin se encuentra en dos archivos, Configuration.h y Configuration_adv.h: solo debes incluir en el archivo comprimido esos dos.

Buenas!! despues de un rato logre encontrarlas, a continuacion te las dejo.


Archivos adjuntos
.rar   Desktop.rar (Tamaño: 77.83 KB / Descargas: 11)
  Responder
#13
Hola, antes de comentarte lo que veo en esos archivos, te recomiendo que utilices la última versión estable y con corrección de errores de Marlin (es la 2.1.x), descargada de su página oficial: no tiene mucho sentido usar la 2.0.8 si vas a tener que compilarla de nuevo.
La configuración de los puertos serie es algo muy importante para el funcionamiento de las comunicaciones, tanto con la tarjeta SD, con la conexión USB y con los drivers TMC, que tienes configurados para su control por software (UART).
En todos los archivos preconfigurados para ese modelo de placa, se asigna el primer puerto serie al número 2 y el segundo al -1, por lo que quizá debas probar a cambiarlos: serían las líneas #define SERIAL_PORT  2 y #define SERIAL_PORT_2  -1
Otra cosa que me ha extrañado, es que está configurada la posición máxima de X e Y a 163 mm, en lugar de los 165 mm que configuras para el tamaño de la cama: con ello estás perdiendo algo de área de impresión y no le sobra precisamente a ese modelo.
En el archivo Configuration_adv.h no veo nada que esté mal configurado.
  Responder
#14
(07-02-2023, 06:18 PM)Simemart escribió: Hola, antes de comentarte lo que veo en esos archivos, te recomiendo que utilices la última versión estable y con corrección de errores de Marlin (es la 2.1.x), descargada de su página oficial: no tiene mucho sentido usar la 2.0.8 si vas a tener que compilarla de nuevo.
La configuración de los puertos serie es algo muy importante para el funcionamiento de las comunicaciones, tanto con la tarjeta SD, con la conexión USB y con los drivers TMC, que tienes configurados para su control por software (UART).
En todos los archivos preconfigurados para ese modelo de placa, se asigna el primer puerto serie al número 2 y el segundo al -1, por lo que quizá debas probar a cambiarlos: serían las líneas #define SERIAL_PORT  2 y #define SERIAL_PORT_2  -1
Otra cosa que me ha extrañado, es que está configurada la posición máxima de X e Y a 163 mm, en lugar de los 165 mm que configuras para el tamaño de la cama: con ello estás perdiendo algo de área de impresión y no le sobra precisamente a ese modelo.
En el archivo Configuration_adv.h no veo nada que esté mal configurado.

Muchas gracias por las correcciones!! lo de la posicion maxima de x e y siendo 163 lo puse al principio de configurar la placa porque probando los motores los mismos seguian de largo y se quedaban trabados, entonces hasta terminar de configurar deje eso y me olvide de cambiarlo, desde ya muchas gracias nuevamente por tu tiempo y ayuda y comentare de nuevo si hay alguna novedad!! saludos y  buena semana.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  conexión pantalla full graphics smart controler albertoteruel 18 6,063 25-02-2022, 09:46 PM
Último mensaje: Macuho
  CONSULTA Conexión impresora con el ordenador ordenador Tonitren 4 422 13-01-2022, 08:30 PM
Último mensaje: Tonitren
  Conexión Prusa i3 Hephestos por USB [Problemas] _RAPTOR_ 4 11,159 22-12-2016, 11:51 AM
Último mensaje: lalomt